Expedition Expedition Navigation Software

You are not logged in. Would you like to login or register?



6/08/2021 11:27 am  #1


C-Maps Error

I'm getting two popups when I open Expedition.  The first is

Error

Error starting C-Map 4D
Is Maps Manager Installed? 

The second is:

Exception

Core::initialize ERROR!!!
Error when initialize CM library (Fonts NOT found.)

I can click okay on the first error and it starts with a white screen.  I can click over to ENCs and everything works.

If I click Okay to the second popup it will close.

I've uninstalled and reinstalled both the latest version of Expedition 4D and Maps Manager but he errors persist. 

I also followed the steps here: https://expedition.boardhost.com/viewtopic.php?id=879 but to no success.

I even went as far as uninstalling Maps Manager and then deleting the whole ProgramData folder, then reinstalled Maps Manager and am having the same issues.

Any ideas?

Last edited by BlueYonderBow (6/08/2021 12:12 pm)

 

6/08/2021 12:26 pm  #2


Re: C-Maps Error

Someone else had this problem recently, but I don't recall how it was solved.

It is presumably a maps manger issue. Normally the solution for most problems with 4D is to reinstall it.

It looks for the fonts in a folder called Resources in Expedition, containing a font configuration and a folder of fonts (6 files) for C-Map. Maybe update or reinstall Expedition?

 

 

6/09/2021 7:03 am  #3


Re: C-Maps Error

Well I was finally able to get everything working but it required a full wipe of Expedition unfortunately.  I had to uninstall then delete all the program files and programdata files left over to start from new (I pulled out the license file to put back in to the new install). 

I had tried doing the above for just Maps Manager but that didn't do it.  

After reinstalling both from scratch everything is working again.  It actually happened on my other copy of Expedition as well so I am going to see if C-Map can help me figure that one out without the full wipe and will let you know if I find the solution and what i did to get there.

     Thread Starter
 

6/09/2021 1:13 pm  #4


Re: C-Maps Error

Did you note what was in the Expedition Resources folder in program files?

 

6/21/2021 12:51 pm  #5


Re: C-Maps Error

Hello,

Another user has the same error. Do you know what the problem was?

 

6/23/2021 12:13 am  #6


Re: C-Maps Error

when you get 
"Error starting C-Map 4D
Is Maps Manager Installed? "

simply restarting the service..  "C-MAP Maps Manager" via the Services application will fix the issue when you restart expedition.

With the other issue.. the only way I've been able to fix it was to do an re-install expedition and select the repair option

 

6/30/2021 1:56 pm  #7


Re: C-Maps Error

Also encountering this issue. No luck restarting the C-Map service. An Expedition repair leads to only the 'unknown exception occured' error and a close to desktop. The contents of the Resources folder are below (this is after a Repair but still with the 'exception' error).

https://i.imgur.com/5EB4yvy.png

https://i.imgur.com/kx77CuR.png


https://i.imgur.com/pikpkd3.png

https://i.imgur.com/4hezYr7.png

Last edited by eb12345 (6/30/2021 2:13 pm)

 

6/30/2021 2:17 pm  #8


Re: C-Maps Error

Several people have had this problem with C-Map this year.

The two exception messages on the left are from C-Map. The two Error messages are Exp saying there appears to be a problem with C-Map.

I don't know what the problem is, but a solution seems be be to uninstall both C-Map Maps Manager and Expedition and reinstall.

 

6/30/2021 2:22 pm  #9


Re: C-Maps Error

Thanks Nick, looks that way.

Have just tried separately reinstalling Expedition and Maps Manager without luck, but reinstalling both (and clearing out Program Data) worked when this occurred last week so hopefully will do so again!

This occurred shortly after running a few routes and an 'out of memory' error if useful to mention (8GB ram).

 

6/30/2021 2:27 pm  #10


Re: C-Maps Error

There is a Resources folder as part of the Expedition install. It contains

4DSDK.cfg
\Fonts

I wonder if it is worth deleting these and letting Exp reinstall them.

8GB doesn't seem to be enough for Windows 10 performance wise, so maybe there is an issue there. I don't know.

 

Board footera

 

Powered by Boardhost. Create a Free Forum

Interested in advertising here? Over a thousand active navigators and Expedition users visit this forum. Click here to contact the administrator.