Expedition Expedition Navigation Software

You are not logged in. Would you like to login or register?

6/03/2021 8:05 am  #1

Downgrade to v10.13

I still had an old Expedition v10 running on Parallels which I sometimes use for race prep.
In a brief stupid moment, I updated this instance without having a v11 licence. Thing is, I don't need an up to date licence for this instance.

Does anybody still have a v10.13 installation file so I can downgrade?
Would be highly appreciated!!!



6/03/2021 12:31 pm  #2

Re: Downgrade to v10.13

email me ..


6/05/2021 4:42 am  #3

Re: Downgrade to v10.13

Sorry to bother you again with this, Nick.
Is there a way to force downgrade / install?
I used ExpeditionSetup_11_9_3.exe to uninstall but when I try to install v10 I get "0x80079666" Another version of this product is already installed..."
I reinstalled ExpeditionSetup_11_9_3.exe and removed it via the Windows Control Panel - same effect.
I manually deleted Expedition folders in ProgrammData and Program Files - same effect.
I tried to clean up reg entries as much as I dared to - still the same effect.

Any ideas?

     Thread Starter

6/05/2021 1:03 pm  #4

Re: Downgrade to v10.13

You might need to uninstall the Microsoft vc_redist.


6/06/2021 8:12 am  #5

Re: Downgrade to v10.13

That solved it!

Cheers, Nick!

     Thread Starter

Board footera


Powered by Boardhost. Create a Free Forum

Interested in advertising here? Over a thousand active navigators and Expedition users visit this forum. Click here to contact the administrator.