Expedition Expedition Navigation Software

You are not logged in. Would you like to login or register?

5/24/2021 10:17 am  #1

C-Map Update Fails

Just tried to update my North West European Chart EW-D227 from within Expedition. After some issues in the C-Map store with scripts not running, I eventually managed to pay for the update. The card was processed and than.... nothing happens. After half an hour without any feedback I leave the store and find an update notification in the My Maps section of C-Map extension within Expedition. The update button is not an actual button, it activates a drop down window with a 0% progress bar. Again for nothing happens. I close C-Map and restart Expedition. Back to the C-Map store. In my account the transaction I just did has an INIT status. Going to My Maps reveals no update anymore, just my old map that I can only Remove or Disable. By now I'm tempted to remove this map altogether, but I resist. Why has C-Map programmed this app so incredibly user unfriendly. No feedback and nowhere a support mail address to be found. Does somebody have a clue what went wrong?



5/25/2021 2:10 am  #2

Re: C-Map Update Fails

Hello, I've had similar issues. The advice I got from C-Map was to remove old charts and download from scratch. I too had the experience that the bar showed 0%, while the download was actually progressing in the background. I agree on the userfriendlyness, every year something weird is going on when updating, and I have to contact support.


6/20/2021 1:22 am  #3

Re: C-Map Update Fails

Thanks NoRay. Sorry for the delay in answering this. Had some nasty Windows 10 .dll file trouble in my laptop.
I just did a clean install and was hoping to finally do an update, but alas. I have 5 FAILED update attempts and 2 INIT's in my transactions in the C-Map Store. The trouble seems to be at evopayments.eu that handles the credit card processing for C-Map.
I've also tried support on the C-Map.com website, but even that failed due to not loading the 'I'm not a robot Captchas'. I give up and wait for the day Navionics opens up their chart data for Expedition.

     Thread Starter

6/20/2021 1:35 am  #4

Re: C-Map Update Fails

Hi Firestorm, I've PM' d you.
FYI . I was able to update my charts on the backup computer, but failed to upgrade the onboard one. Allthough I am connected tyo the internet, MapManager thinks I am not. There the story ends. It is a cumbersome process everytime.


6/23/2021 12:08 pm  #5

Re: C-Map Update Fails

Hi NoRay,

Thanks for the contact. Victory at last, C-Map support came up,with a solution \o/

After filling out the credit card details for the upgrade, you get a lot of script warnings eventually leading to a blank screen. Don’t worry, persevere. Close the C-Map Map Manager shop, go back to Expedition and restart the Map Manager. In your account the transaction is marked as INIT. Close the shop and go to My Maps. Now comes the scary part: remove your current map. Then again nothing happens. By now you must get used to this. Close and restart Maps Manager and there is a download button for your new map. The rest is self explanatory. Totally illogical even for Vulcans, but nevertheless succesful. Anyway I’m covered for the coming Fastnet. 

Live long and prosper,


     Thread Starter

Board footera


Powered by Boardhost. Create a Free Forum

Interested in advertising here? Over a thousand active navigators and Expedition users visit this forum. Click here to contact the administrator.