Expedition Expedition Navigation Software

You are not logged in. Would you like to login or register?

7/12/2017 4:06 pm  #1

Playback | Simulate mode interfering with onboard use

Hi -

I've used the simulation mode in Expedition a few times - setting the boat position manually and having it run a course. When I take it to the boat, plug in the instruments, the data is showing what the simulator is doing. Obviously, I turned off the simulator but then no data is shown. The only way I can describe this is that it seems like Expedition thinks I'm still in simulator mode even after I turned off and is ignoring the actual data coming from the instruments.

Any help appreciated. 



7/12/2017 4:24 pm  #2

Re: Playback | Simulate mode interfering with onboard use

Maybe check you have data from the instruments in the raw data window.


7/13/2017 12:13 pm  #3

Re: Playback | Simulate mode interfering with onboard use

Nick - thanks for the reply. I shutdown the laptop completely and restarted. This stopped expedition log data from being written from the simulator. I took the laptop back to the boat - connected the RS-232 the serial port - COM1.  I am not seeing any data in the raw data window for what is COM1. I checked all the other COM ports and all of them are inactive. COM1 is set to NMEA 0183 | 4800 baud | 8 Data Bits | Parity None | Stop Bits 1, Boat(0) def.  The boat has older Raymarine electronics with the RS-232 wired into what appears to a bridge .

What is strange is that if I view the log file in a text editor - I captured one record that was AWA and AWS which is valid instrument data from the boat. So, I know there is some communication going on between the laptop and the bridge but can't figure out what it stopped working. Here are a couple of things I've changed recently:

- Added Ventus Navigation UDP broadcast over Network interfaces
- Updated to the latest revision of Expedition
- Have been running a lot of simulations and weather routing with a start point other than the boat's current location.
- Disabled windows firewall to check if that had an impact (none noticed)

Any help appreciated ..


     Thread Starter

7/13/2017 2:47 pm  #4

Re: Playback | Simulate mode interfering with onboard use

It probably doesn't help much, but if you are receiving NMEA data, it will be appearing in one of the raw data windows.

​You should also see awa & aws on a number box in this case for example.


7/14/2017 6:35 am  #5

Re: Playback | Simulate mode interfering with onboard use

As Nick indicates, first check (in the Exp instruments settings) if you get raw data on the COM port you expect.
Further, you can check:
- Is "validate checksum" enabled (normally it shoud not differ but I would just try)
- In the NMEA settings of the COM port, are the sentences you expect to receive from your instruments enabled?
- Is it really 4800 baud you receive?  Try 9600 and 34800 as well
- Is there no other software running on your PC that uses the COM port already?  (e.g.   setup software for a NMEA multiplexer or your bridge).  If so, close it and start Exp again.

hope this helps!

Last edited by ZeeZee (7/14/2017 6:37 am)


7/14/2017 8:25 am  #6

Re: Playback | Simulate mode interfering with onboard use

I had some really weird instrument comms problems: it turned out to the the drivers for a display port docking station. I'd check your serial comms drivers carefully. In my case I could see data in the serial comms boxes in exp, and do some comms operations with the B&G such as uploading and downloading config data , but exp wouldn't recognise the instrument or GPS data. I had no data in data boxes, nor position data, yet I could edit the B&G's polars!  In my set up I have two USB feeds: an FDDI RS232 adaptor to the B&G serial port and a USB connected Shipmodul Multiplexor. I spent ages trying to sort it out, rebuilt the PC, switched from Win7 to Win10, proved Exp & the boat worked fine with a mac running VMWare, and finally it all worked perfectly with the display port driver update. It's clear to me from my experience that windows driver issues can result in data being partially available in Exp. Nick was endlessly helpful and supportive, but obviously couldn't really help fix my windows config. As a former software engineer I can attest that the symptoms were really weird, and I'm not sure I could explain them even now!


7/14/2017 1:28 pm  #7

Re: Playback | Simulate mode interfering with onboard use

Hi All - 

Thanks for everyone support. Finally tracked down the problem. Windows 7 applied a stealth update overnight. It somehow switched COM1 and COM2. So, expedition was setup for COM1, then the same COM1 sent out nothing (even though it was "open"). COM2 was closed. I setup COM2 to receive NMEA sentences and it started working. The upside was learning to use the raw data button which definitely works and will show data if something is coming in. Also, experimented with a NMEA simulated broadcaster which I installed on another computer on the same network. When I told expedition to open a network port to listen to the NMEA simulates broadcasts - worked no problem.

I'm really not sure how COM1 and COM2 got switched - I'm almost positive I didn't switch it, but I was in there setting up network connections to test the Ventus UDP broadcaster so maybe I did something. Hope this helps anyone having a similar issue.

     Thread Starter

Board footera


Powered by Boardhost. Create a Free Forum

Zapfware North University. Racing Tactical Software - Expedition.
Online courses