Expedition Expedition Navigation Software

You are not logged in. Would you like to login or register?



4/29/2016 5:43 pm  #1


NMEA Simulator

FYI - In case it can help anyone else.

I ran across this free NMEA simulator chrome plugin when looking for a way to test setting up instruments

https://chrome.google.com/webstore/detail/nmea-simulator/dfhcgoinjchfcfnnkecjpjcnknlipcll?hl=en

I was able to set it up on either the same system running Expedition or another computer on the same network and test receiving NMEA data via the network.
 

 

4/30/2016 10:29 am  #2


Re: NMEA Simulator

Just downloaded and set it up.  Very interesting.  Trying to understand why I get SOG but not BSP.  will require some deeper investigation.

 

5/02/2016 5:48 pm  #3


Re: NMEA Simulator

You guys are technically way in front of me. Note that I am doing this on a laptop not connected to any instruments in the comfort of my office desk!
In order to configure Expedition to receive the "data", I assume you create a new network port (say Network 1), then set Instruments=NMEA0183, Connection=TCP Client, use the computer's IP address and any port will do .... but it doesn't work, so I am missing something
Cheers 

 

5/02/2016 7:11 pm  #4


Re: NMEA Simulator

If you are running the simulator on the same computer as Expedition then in the simulator set the IP to 127.0.0.1 (default local host IP) and any port*  
* port must match when you configure Expedition.
The setting you state are correct, just make sure the ports match.  That should be it.
If running the simulator on a different system just need to make sure your laptop can "see" the computer you are running the simulator on.  Same network etc.. and no firewall's in place.
I had "Boat" set to 0.  "Tx on port + 1" unchecked.  Under NMEA settings almost all NMEA and XDR sentences are checked.
If you connect the plugin will pop up a box saying it sees a client.  Raw data will stream the raw NMEA sentences once connected.

     Thread Starter
 

5/03/2016 2:41 pm  #5


Re: NMEA Simulator

Tks.  Makes it easy.
Cheers

 

5/04/2016 4:50 am  #6


Re: NMEA Simulator

OK experts, I got 2/4 to work:
"Speed" = SOG
"Heading" = COG
"Windspeed" = Don't know, certainly I can't get a result in any of TWS, AWS or MWS..
"Wind Direction" = Don't know, not TWD and Expedition doesn't record AWD.or MWD as TWD is calculated.
Looked at the B&G manual and had glasses of wine instead.  Good choice!

 

3/12/2018 1:47 pm  #7


Re: NMEA Simulator

Hi there,
Hope someone can help me out here.
I try to get this NMEA simulator to work (so not on the same computer) as I think when I am able to get this work, I will also be able to get the NMEA data into Expedition on the boat (this is obviously the real problem)
I have a lovely new laptop, but I am just not able to get the data in.
I copied all the settings from the old laptop, but this doesn't work.
Please note that on the boat I have the B&G 2000 plus AIS via a multiplexer through a wifi Router. With the old laptop, it worked like a charm.

I think my problems have something to do with IP adresses and Ports so that why I wanted to practice with the Simulator first. 

DuncanR mentions above "I assume you create a new network port (say Network 1)".
I tried to do this by "forwarding the port" and assign it to the laptop's IP address. Is this what you mean by creating a new network?

Does someone recognise my problem and is able to help me out here?

Thanks!

Mitch

 

 

3/12/2018 1:59 pm  #8


Re: NMEA Simulator

https://imgur.com/Nfj8EiO
Here are the settings on the old laptop.The simulator doesn't have AIS , so I guess you have to choose NMEA 0183 in the instrument box.

https://imgur.com/Nfj8EiOhttps://imgur.com/Nfj8EiO

 

3/14/2018 8:01 pm  #9


Re: NMEA Simulator

In case you are still playing around with this. 
It took me some time to re-familiarize myself with how to get this to work.
On a spare laptop I had, I started up the Simulator.
Under,   Options->Settings-->Server

I selected TCP/IP,  TCP Server,  set the IP to the IP of the laptop, 192.168.1.227, in my case.  I left the port alone but you should be able to set this to anything.

Then on the computer running expedition I had the following:
Under Instruments:  Network 0
Instrument Type: NMEA0183
Connection: TCP client
Address:  (IP of laptop) 192.168.1.227
Port: Same port you used when setting up Simulator
Tx on port+1,  unchecked.  I am unclear what this does except to rebroadcast certain data.
Boat was set to 0.

I had to hit apply to have it save the settings, then reconnect. 

I left all settings on Right side of screen alone.

Easiest way to check if it working is to hit the "Raw data" button.  You should see some NMEA sentences streaming.

Hope that helps




 

     Thread Starter
 

Board footera

 

Powered by Boardhost. Create a Free Forum

Zapfware North University. Racing Tactical Software - Expedition.
Online courses