Expedition Expedition Navigation Software

You are not logged in. Would you like to login or register?



12/26/2018 1:08 pm  #1


Problem finding Ventus Pro Ap for I-Pad2

I am setting up an older I-Pad2 (iOS 10.3.3), and I cannot find Ventus Nav Pro on the App Store.  I have purchased Ventus Pro, and use it on another I-Pad2, but I am not able to find it with the I-Pad I am setting up.  Is the current version of Ventus no longer supported by older I-Pads?  Is there any way to get the same Ventus version I am currently using on the initial I-pad2, loaded onto the I-Pad2 that I am currently setting up?  Can anyone help a confused soul?

 

12/27/2018 2:43 pm  #2


Re: Problem finding Ventus Pro Ap for I-Pad2

Ventus PRO should run on any Apple device using iOS 8 or later. When you go to the App store you need to click on iPhone apps and download it from there.

Harry

 

12/27/2018 3:02 pm  #3


Re: Problem finding Ventus Pro Ap for I-Pad2

Thanks Harry.  Your suggestion worked.  I don't remember needing to select I-Phone Aps in the past, but it worked and I have down loaded it onto the I-Pad. You have made my day.  Thanks Santa!

     Thread Starter
 

Board footera

 

Powered by Boardhost. Create a Free Forum

Zapfware North University. Racing Tactical Software - Expedition.
Online courses